Build the best - destroy the rest!

Wednesday, 30 January 2013


Robocode version is the first version that requires Java 6.


  • Bug-346: Cannot extract sources from robot packages.
  • Bug-348: .NET: UnauthorizedAccessException in AppDomainShell.Dispose().


  • Robocode has been updated to Java 6, and hence this will be the new minimum requirement for running Robocode from this version.
  • The icon for Robocode was upgraded to a 256x256 pixel resolution.
  • Added the new properties -DlogMessagesEnabled=true|false and -DlogErrorsEnabled=true|false for enabling and disabling log messages and log errors.
    • The robocode.control.RobocodeEngine has got two similar methods: setLogMessagesEnabled(boolean) and setLogErrorsEnabled(boolean).
Download Robocode from here
Download Robocode .NET plug-in from here
Download Robot testing plug-in from here